Bypass traceroute traffic

By admin

Pada mesin modern, aplikasi traceroute biasa mempergunakan protokol UDP dari pada ICMP.

Oleh karena itu bila admin sudah membaypass icmp, maka yang di dapat ping time akan stabil pada saat utilitas traffic full.

Tapi pada saat kondisi yang sama bila dilakukan traceroute, hasilnya berbeda signifikan.

Setelah menganalisa paket traceroute dengan tcpdump dan panduan dari wiki, didapat pada saat aktifitas traceroute berjalan, dia membuka sesi udp menuju port 33434 incremental pada setiap hop yang dilalui.

/ip firewall mangle

add chain=prerouting action=mark-connection \
    new-connection-mark=trace-con passthrough=yes \
    src-address=192.168.1.0/24 dst-port=33434-33534 \
    protocol=udp comment="" disabled=no 

add chain=prerouting action=mark-packet \
    new-packet-mark=tracert passthrough=no \
    connection-mark=trace-con comment="" \
    disabled=no

Karena limiter ditempat saya mempergunakan simple queue, maka saya tambahkan ini queue tambahan di baris paling atas.

/ queue simple
add name="traceroute" dst-address=0.0.0.0/0 \
    interface=all parent=none \
    packet-marks=tracert direction=both priority=1 \
    queue=default-small/default-small \
    limit-at=0/0 max-limit=0/0 \
    total-queue=default-small disabled=no

4 Comments

  • At 2009.05.12 03:20, angkol31 said:

    KK udah coba tapi kgak mau counter mangle nya, dan setelah saya tourch hanya protokol icmp saja ketika melakukan traceroute !

    Ada solusi, saya pake RouterOS 3.23 on x86

    THX B4

    • At 2009.06.12 15:04, mikrotik said:

      sama….ama yang diatas

      • At 2012.04.07 15:55, agung said:

        192.168.1.0/24 ini ip apa om?

        • At 2012.04.13 13:21, human said:

          Contoh ip-sumber(PC) yang akan di baypass supaya millisecond traceroute juga kecil

        (Required)
        (Required, will not be published)