Compile spine 0.8.7b di debian

By admin

Error pada waktu kompile

cacti-spine-0.8.7a# ./configure
configure: error: cannot run /bin/sh config/config.sub

Setelah di investigasi di google, ternyata belum ada library libtool

apt-get install libtool

Setelah masalah libtool selesai, muncul lagi masalah berikutnya :d

$ ./configure
...
...
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.22, ltmain.sh = "1.5.22 Debian 1.5.22-4") ***

Please run:

  libtoolize --copy --force

Solusinya dari forum :

$ aclocal
$ libtoolize --copy --force
Putting files in AC_CONFIG_AUX_DIR, `config'.
$ autoconf
$ autoheader
$ ./configure

2 Comments

  • At 2008.07.01 17:30, Agus Priyadi said:

    abaikan error dari aclocal
    beberapa kasus ./configure membutuhkan librart mysql dan library snmp. tambahkan perintah berikut

    apt-get install libmysqlclientX-dev libsnmpX-dev

    dimana X adalah versi yang didapat dari apt-cache search

    apt-cache search libmysqlclient | grep dev
    apt-cache search libsnmp | grep dev

    • At 2008.07.01 17:32, admin said:

      Mantab

      (Required)
      (Required, will not be published)