Cisco:blocking vlan on port cause by inconsistent peer vlan id

By human

00:02:05: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 302 on GigabitEthernet0/16 VLAN999.
00:02:05: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet0/16 on VLAN0999. Inconsistent local vlan.
00:05:49: %LINK-3-UPDOWN: Interface GigabitEthernet0/4, changed state to down

Kasus diatas biasa terjadi bila kita memakai switch yang terhubung dengan perangkat switch lain yang tidak dalam wewenang kita (misal provider lain). Saya sudah 2x mengalami hal ini dengan provider yang berbeda, dgn kasus yang sama.

Untuk solusi cepat diatas bisa dengan mengaktifkan bpduguard di switch agar mengabaikan setiap paket bpdu yang tidak sesuai.

interface GigabitEthernet0/16
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 999,1144
 switchport mode trunk
 spanning-tree bpdufilter enable
 spanning-tree bpduguard enable
end
Interface mode:
spanning-tree bpduguard enable                       (Puts port in errdisable upon receiving any bpdu).
Global mode:
spanning-tree portfast bpduguard default           (It enables bpduguard on ports that have port-fast configuration, puts port in errdisable upon receiving a bpdu).

Interface mode:
spanning-tree bpdufilter enable                        (Results port to not participate in STP, loops may occur).
Global mode:                                                 
spanning-tree portfast bpdufilter default             (It enables bpdufiltering on ports that have port-fast configuration, so it sends a few bpdu while enabling port then it filters bdpu unless receives a bpdu, after that itchanges from port-fast mode and disables filtering for port to operate like a normal port cause it has received bpdu).

Hasilnya port yang terbloking secara vlan dapat kembali restore.

03:03:53: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking GigabitEthernet0/16 on VLAN0999. Port consistency restored.

Minusnya : – belum tahu

literatur dari bisa dibaca dari sini
Importance of BPDU Guard and BPDU Filter !!

No Comments

(Required)
(Required, will not be published)