Shorewall 4.x di TSL 3.0.5

Instan firewall yang mudah cara instalasinya.
Supaya saya tidak lupa dan bermanfaat buat yang lain, maka saya dokumentasikan saja :D.

Untuk trustix, dan “mungkin” distro lain yang tidak spesifik, sebaiknya ambil paketan “noarch”.
Bisa juga pakai versi tgz. Tapi saya lebih memilih yang rpm, biar ndak mumet. Namanya juga mau instant

Contoh kasus, shorewall akan dipasang di mesin mail dengan 1 interface, dan versi terbarunya 4.0.11
Read more »

How to change dynamic queues

Diambil dari forum.mikrotik.com

Saya belum bisa mendeskripsikan secara jelas fungsi script di bawah.
Tetapi dari thread di topik, ini berfungsi untuk mengganti rate di user pada saat koneksi sedang berjalan.

Read more »

Mikrotik: case hotspot stiki.ac.id

Kasus ini ditanyakan ke saya oleh mas Ronny Susetyo aka ballacksave, admin (ngaku-nya newbie) stiki.ac.id via YM

topologi-stiki.gif

Nah pertanyaan saya pada dasarx sama seperti dasep yaitu bgm client yg di bawah mikrotik
(dosen, sabarnet,hotspot) klo buka jaringan yg diatas mikrotik seperti webserver, mail dan webhosting (203.134.237.0/29) bisa nggak ke limit, tapi klo browsing ke internet tetep ke limit.
nb:
di mikrotikx saya pake /ip hotspot, untuk bagi2 bandwidthx……
mohon pencerahan…

Read more »

Bypass traceroute traffic

Pada mesin modern, aplikasi traceroute biasa mempergunakan protokol UDP dari pada ICMP.

Oleh karena itu bila admin sudah membaypass icmp, maka yang di dapat ping time akan stabil pada saat utilitas traffic full.

Tapi pada saat kondisi yang sama bila dilakukan traceroute, hasilnya berbeda signifikan.

Setelah menganalisa paket traceroute dengan tcpdump dan panduan dari wiki, didapat pada saat aktifitas traceroute berjalan, dia membuka sesi udp menuju port 33434 incremental pada setiap hop yang dilalui.
Read more »

Burst for each TCP connection

Diambil dari http://forum.mikrotik.com/viewtopic.php?t=12870

This is little how-to create manual burst using queue tree.

As it is bandwidth control using queue tree first we need to mangle traffic

first i mangle all connections, then i mark first 2Mbytes then i mark the rest of packets

/ip firewall mangle add chain=forward protocol=tcp \
action=mark-connection \
new-connection-mark=new_conn passthrough=yes \
comment="mark all new connections" disabled=no

/ip firewall mangle add chain=forward protocol=tcp  \
connection-mark=new_conn \
connection-bytes=0-2000000 action=mark-packet \
new-packet-mark=new_packet passthrough=no \
comment="mark packets" disabled=no

/ip firewall mangle add chain=forward protocol=tcp \
connection-mark=new_conn action=mark-packet \
new-packet-mark=old_packets passthrough=no \
comment="marking old packets" disabled=no

Read more »

Bypass icmp via htb.init

Kalau pakai script htb.init biasa kita bisa membaypass icmp supaya ping time kecil.

Selama ini saya berpikir untuk membaypass harus pakai teknik mangle di firewall.

Ternyata hal itu tidak sepenuhnya benar.

Setelah di ajari oleh master-nya noc isp di semarang baru tahu saya, kalau itu bisa tanpa mangle.

Procedurenya :

buka file htb.init di /var/cache

tambahkan baris ini di bawah baris

/sbin/tc qdisc del dev eth0 root
/sbin/tc qdisc add dev eth0 root handle 1 htb default 0 r2q 100

/sbin/tc qdisc del dev eth1 root
/sbin/tc qdisc add dev eth1 root handle 1 htb default 0 r2q 100
/sbin/tc class add dev eth0 parent 1: classid 1:2 htb rate 128kbit
/sbin/tc class add dev eth1 parent 1: classid 1:2 htb rate 128kbit
/sbin/tc filter add dev eth0 parent 1: protocol ip prio 1 u32 match ip protocol 1 0xff flowid 1:2
/sbin/tc filter add dev eth1 parent 1: protocol ip prio 1 u32 match ip protocol 1 0xff flowid 1:2