Mikrotik: membuat hotspot baypass traffic IIX

Karena pertanyaan dari mas andy (andy_m3m@yahoo.co.id) di topik hotspot sebelumnya.

Saya buatkan post sendiri untuk masalah ini.

Di tempat saya, saya sudah mengaplikasikan ini sekitar 2~3 bulan yang lalu.
Pada saat itu memang kebutuhan saya untuk melimit internasional agar terbagi rata, tetapi untuk ke IIX tidak di limit. Rupa-nya tidak hanya saya yang berniat dengan konfigurasi seperti ini.
Read more »

Squid zph and Mikrotik

Bonus tambahan dari squid 2.7-stable3 adalah fungsi zph yang sudah terintegrasi.

ZPH sendiri adalah Zero Penalty Hit, penjelasan-nya bisa dibaca di http://zph.bratcheda.org/

Pada 2.7 sudah masuk dalam core engine squid.
Sebelum versi 2.7 harus melakukan patch.

Tutorial di bawah ini saya memakai squid dari caching youtube.

Read more »

Burst for each TCP connection

Diambil dari http://forum.mikrotik.com/viewtopic.php?t=12870

This is little how-to create manual burst using queue tree.

As it is bandwidth control using queue tree first we need to mangle traffic

first i mangle all connections, then i mark first 2Mbytes then i mark the rest of packets

/ip firewall mangle add chain=forward protocol=tcp \
action=mark-connection \
new-connection-mark=new_conn passthrough=yes \
comment="mark all new connections" disabled=no

/ip firewall mangle add chain=forward protocol=tcp  \
connection-mark=new_conn \
connection-bytes=0-2000000 action=mark-packet \
new-packet-mark=new_packet passthrough=no \
comment="mark packets" disabled=no

/ip firewall mangle add chain=forward protocol=tcp \
connection-mark=new_conn action=mark-packet \
new-packet-mark=old_packets passthrough=no \
comment="marking old packets" disabled=no

Read more »