Mikrotik::PCQ Hotspot

Di kopi dari tulisan Sudipta Kr.Pal di mum mikrotik, catatan pribadi supaya tidak lupa.
di tes memakai mikrotik versi 6.37.1

  1. Buat user profile baru
    /ip hotspot user profile \
            add incoming-packet-mark=Gold_IN name=Gold outgoing-packet-mark=Gold_OUT shared-users=1
  2. Buat queue type
    /queue type \
            add kind=pcq name=Gold_download pcq-classifier=dst-address pcq-rate=1m
            add kind=pcq name=Gold_upload pcq-classifier=src-address pcq-rate=1m
  3. Buat firewall mangle
    /ip firewall mangle
            add action=jump chain=forward jump-target=hotspot

Untuk step berikutnya silakan di tebak :)

Semoga bermanfaat

Mikrotik: ibgp route reflect

Sempat bingung, kenapa route yang didapat dari router iix atau oixp ndak bisa diteruskan ke router lain.

Bahan2 yang dipakai;
2 router cisco yang berhadapan langsung dengan oixp dan iix.
1 router mikrotik v 5.21.
Topologi seperti gambar sederhana dibawah;
simple topologi ibgp
Rupanya hal ini merupakan default konfig mikrotik (?). Bagusnya adalah admin tidak perlu takut salah konfig yang menyebabkan route rembes/bocor kemana2. Apesnya kalau niatnya memang mau disebarin, seperti yang dialami saat ini.

Default dari konfig instance di mikrotik sbb :
Read more »

OSPF: beda type untuk adv-network dan redistribute

#sh ip route xx.xxx.57.250
Routing entry for xx.xxx.57.248/30
  Known via "ospf 100", distance 110, metric 20, type intra area
  Last update from xx.xxx.56.6 on FastEthernet0/1.711, 00:00:05 ago
  Routing Descriptor Blocks:
  * xx.xxx.56.6, from xxx.xxx.127.232, 00:00:05 ago, via FastEthernet0/1.711
      Route metric is 20, traffic share count is 1
sh ip route xx.xxx.57.246
Routing entry for xx.xxx.57.244/30
  Known via "ospf 100", distance 110, metric 20, type extern 2, forward metric 1                                             0
  Last update from xx.xxx.56.6 on FastEthernet0/1.711, 00:00:03 ago
  Routing Descriptor Blocks:
  * xx.xxx.56.6, from xxx.xx.127.232, 00:00:03 ago, via FastEthernet0/1.711
      Route metric is 20, traffic share count is 1

kalau di adv-networknya akan ditulis type intra area
kalau di buat redistribut connected akan ditulis type extern 2

Mikrotik: interface wan down (again ???) arghh

Seperti janji saya (buat yang merasa di janjikan), saya bahas misteri dibalik disable-nya interface wan.

Intro terlebih dahulu.

Ditempat saya ada pc mikrotik (named kebab, nyam nyam) yang dipergunakan untuk keperluan router internal.
Ether dengan ip public di rename menjadi WAN, sedangkan ether dengan ip private di rename LAN.
Di pc ini disetup hotspot untuk login-berautentifikasi.

Yang menjadi kendala interface wan, bolak balik mati, dalam 1 hari (kalau apes) bisa berkali-kali.

Read more »

Antara Mikrotik, BPDU, Switch

Gagal konfigurasi link GK-NG3 via mikrotik.

AP ada disisi NG3, dengan konfigurasi 2 wlan.
wlan 1 sebagai client, posisi AP dari GK
wlan 2 sebagai AP untuk BSD

vlan untuk wlan 2 dapat berfungsi dengan normal.
vlan untuk wlan 1 tidak berfungsi normal, dari investigasi, di cisco switch GK muncul log seperti di bawah. Masalah BPDU.

BPDU adalah protokol yang dipergunakan swith dalam mengatur rootbridge di aplikasi spantree.
Bisa di baca di wikipedia

Muncul pemikiran hal ini dikarena dalam 1 routerboard beda konfigurasi, 1 sebagai AP dan lainnya sebagai client.

Di lakukan perubahan posisi, sehingga kedua AP ada di NG3, di GK sebagai client.
Masih tetap muncul log seperti dibawah, dan antar router GK dan NG3 tidak bisa ping.

Read more »

Mikrotik: membuat hotspot baypass traffic IIX

Karena pertanyaan dari mas andy (andy_m3m@yahoo.co.id) di topik hotspot sebelumnya.

Saya buatkan post sendiri untuk masalah ini.

Di tempat saya, saya sudah mengaplikasikan ini sekitar 2~3 bulan yang lalu.
Pada saat itu memang kebutuhan saya untuk melimit internasional agar terbagi rata, tetapi untuk ke IIX tidak di limit. Rupa-nya tidak hanya saya yang berniat dengan konfigurasi seperti ini.
Read more »