Squid zph and Mikrotik

Bonus tambahan dari squid 2.7-stable3 adalah fungsi zph yang sudah terintegrasi.

ZPH sendiri adalah Zero Penalty Hit, penjelasan-nya bisa dibaca di http://zph.bratcheda.org/

Pada 2.7 sudah masuk dalam core engine squid.
Sebelum versi 2.7 harus melakukan patch.

Tutorial di bawah ini saya memakai squid dari caching youtube.

Read more »

Cacti 0.8.7 and 1 minute polling

Dulu tidak tahu, sekarang lupa :D.
Untung ada agus miyabi yang bantuin, he he he, mana uda sore waktunya go home.

Yang ingin mencoba, diharapkan sudah pernah menginstall cacti untuk 5 minutes polling.
Supaya dasar-dasar pemakaian cacti tidak bingung.

Aplikasi yang saya pakai cacti 0.8.7b dan spine 0.8.7a.

Read more »

Instalasi Maia Mailguard di Ubuntu 8.04 Server

Tulisan asli dokumen ini mempergunakan ubuntu 6.06 dibuat oleh bang cecep dapat di lihat di situs ini
Instalasi Maia Mailguard di Ubuntu 6.06 Server (LTS)

Untuk versi 8.04 ada sedikit perbedaan di php dan smarty.
Juga saya tambahkan beberapa clue agar maia dapat langsung berjalan, tanpa harus trouble-shot lagi.

Pastikan postfix sudah terinstall dan berfungsi dengan baik dan benar.
Edit file master.cf pada postfix untuk menerima request dari port 10025.

vi /etc/postfix/master.cf
127.0.0.1:10025 inet n  -       n     -       -  smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
/etc/init.d/postfix restart

Read more »

Postfix-postfixadmin-dovecot di trustix 3.05

Pada panduan ini, tidak dijelaskan memakai fasilitas qouta dan SALS.

Pilih paket-paket instalasi seperti contoh dibawah. Agar Trustix tetap ramping.

paketan di trustix

Read more »

Mikrotik: DHCP Pool usage

Diambil dari http://forum.mikrotik.com/viewtopic.php?f=9&t=19389

tested on 3.7

# WarnAt needs to be at what percentage you want to be warned you are running out of IP addresses.
:local WarnAt 10
#Name of DHCP Pool you want to monitor
:local DHCPPoolName dhcp_pool1
#Your Email to notify you when running out of available ip's
:local Email my@email.com
#Your mail server ip address
:local EmailServer 0.0.0.0

#Declare Variable
:local Total

:foreach i in=[/ip pool get $DHCPPoolName ranges] do={
#Get the DHCP pool range and put into a string.
:local range [:tostr $i]
#Get the Start address of the range
:local Start [:pick $range 0 [:find $range "-"]]
#Get the End address of the range
:local Stop [:pick $range ([:find $range "-"] + 1) 31]
#Calculate how many IP's are in the Pool by subtracting the end address and the start address and add one.
:local ip ($Stop - $Start +1 )
#Save the size of the pool to Total
:set Total ($ip + $Total)
}

#Get the name of the Server that is using the Pool
:local Server [/ip dhcp-server get [/ip dhcp-server find address-pool="$DHCPPoolName"] name]
#Get the number of IP address's used in the pool
:local Used [/ip dhcp-server lease print count-only where server=[/ip dhcp-server get [/ip dhcp-server find address-pool=$DHCPPoolName] name]]
#Subtract used from total to get available
:local Available ($Total - $Used)
#Calculate percentage IP's available
:local Perc (($Available * 100) / $Total)
#Setup e-mail
:local Subject ([/system identity get name] . " DHCP pool is at $Perc")
:local Body ("Out of $Total addresses you have $Available available")

#Send out Email when available ip's percentage is below or equal to warnat
:if ($Perc <= $WarnAt) do={
/tool e-mail send to=$Email subject=$Subject body=$Body server=$EmailServer
}
:log info $Body

Fetch Tool

Di posting dari email newsletter mikrotik.com, fitur baru yang ada di versi 3.x.

Akan sangat berguna untuk mendonlot file nice.rsc dari mikrotik.co.id :D

For some time now, RouterOS has a neat little feature – it’s called Fetch.
It is a HTTP and FTP client program that allows you to download iles to your router.

For example fetch in action:

[admin@I] /tool> fetch address=human.network.com \
path=index.php host=forum.mikrotik.com
status: connecting

status: downloading
downloaded: 7KiB
duration: 1s

atau bila gagal coba dengan syntax url

[admin@I] /tool> fetch url=http://ixp.mikrotik.co.id/download/nice.rsc