Squid zph and Mikrotik

Bonus tambahan dari squid 2.7-stable3 adalah fungsi zph yang sudah terintegrasi.

ZPH sendiri adalah Zero Penalty Hit, penjelasan-nya bisa dibaca di http://zph.bratcheda.org/

Pada 2.7 sudah masuk dalam core engine squid.
Sebelum versi 2.7 harus melakukan patch.

Tutorial di bawah ini saya memakai squid dari caching youtube.

Read more »

Caching Youtube

Puas rasanya, akhirnya bisa caching youtube (dan yang similar) :D.
Setelah sekian bulan “mangkrak” akhirnya jalan juga walau masih di mesin virtualbox.

Howto ini bukan untuk para pembenci youtube dan googlemap.
Tapi untuk youtube dan googlemap lovers.

bahan referensi yang jadi bacaan.
http://www.mail-archive.com/squid-users@squid-cache.org/msg54605.html
http://www.mail-archive.com/squid-users@squid-cache.org/msg51076.html
http://wiki.squid-cache.org/Features/StoreUrlRewrite
http://wiki.squid-cache.org/Features/StoreUrlRewrite/RewriteScript
Read more »

Shorewall 4.x di TSL 3.0.5

Instan firewall yang mudah cara instalasinya.
Supaya saya tidak lupa dan bermanfaat buat yang lain, maka saya dokumentasikan saja :D.

Untuk trustix, dan “mungkin” distro lain yang tidak spesifik, sebaiknya ambil paketan “noarch”.
Bisa juga pakai versi tgz. Tapi saya lebih memilih yang rpm, biar ndak mumet. Namanya juga mau instant

Contoh kasus, shorewall akan dipasang di mesin mail dengan 1 interface, dan versi terbarunya 4.0.11
Read more »

Bypass traceroute traffic

Pada mesin modern, aplikasi traceroute biasa mempergunakan protokol UDP dari pada ICMP.

Oleh karena itu bila admin sudah membaypass icmp, maka yang di dapat ping time akan stabil pada saat utilitas traffic full.

Tapi pada saat kondisi yang sama bila dilakukan traceroute, hasilnya berbeda signifikan.

Setelah menganalisa paket traceroute dengan tcpdump dan panduan dari wiki, didapat pada saat aktifitas traceroute berjalan, dia membuka sesi udp menuju port 33434 incremental pada setiap hop yang dilalui.
Read more »

Burst for each TCP connection

Diambil dari http://forum.mikrotik.com/viewtopic.php?t=12870

This is little how-to create manual burst using queue tree.

As it is bandwidth control using queue tree first we need to mangle traffic

first i mangle all connections, then i mark first 2Mbytes then i mark the rest of packets

/ip firewall mangle add chain=forward protocol=tcp \
action=mark-connection \
new-connection-mark=new_conn passthrough=yes \
comment="mark all new connections" disabled=no

/ip firewall mangle add chain=forward protocol=tcp  \
connection-mark=new_conn \
connection-bytes=0-2000000 action=mark-packet \
new-packet-mark=new_packet passthrough=no \
comment="mark packets" disabled=no

/ip firewall mangle add chain=forward protocol=tcp \
connection-mark=new_conn action=mark-packet \
new-packet-mark=old_packets passthrough=no \
comment="marking old packets" disabled=no

Read more »

How to stop (smtp) viruses !!

Diambil dari http://forum.mikrotik.com/viewtopic.php?t=11474

Hi, i created these 2 simple rules for firewall forward and this work very fine…… do not say it to anybody ;) :D

2 ;;; BLOCK SPAMMERS OR INFECTED USERS
chain=forward protocol=tcp dst-port=25 \
src-address-list=spammer action=drop

3 ;;; Detect and add-list SMTP virus or spammers
chain=forward protocol=tcp dst-port=25 connection-limit=30,32 \
limit=50,5 src-address-list=!spammer action=add-src-to-address-list \
address-list=spammer address-list-timeout=1d

When detect an infected user with a worm or doing spamming this rule add this user to a spammer list and block the SMTP outgoing for 1 day ;)

Regards!
Alessio