Gagal install perl via CPAN di ubuntu 7.10

# perl -MCPAN -e 'install IP::Country'
...
...
Checking if your kit is complete...
Looks good
Writing Makefile for IP::Country
-- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

Masalah ini muncul ketika saya ingin mengintall model perl via CPAN di ubuntu 7.10.
Read more »

Shorewall 4.x di TSL 3.0.5

Instan firewall yang mudah cara instalasinya.
Supaya saya tidak lupa dan bermanfaat buat yang lain, maka saya dokumentasikan saja :D.

Untuk trustix, dan “mungkin” distro lain yang tidak spesifik, sebaiknya ambil paketan “noarch”.
Bisa juga pakai versi tgz. Tapi saya lebih memilih yang rpm, biar ndak mumet. Namanya juga mau instant

Contoh kasus, shorewall akan dipasang di mesin mail dengan 1 interface, dan versi terbarunya 4.0.11
Read more »

Mikrotik: DHCP Pool usage

Diambil dari http://forum.mikrotik.com/viewtopic.php?f=9&t=19389

tested on 3.7

# WarnAt needs to be at what percentage you want to be warned you are running out of IP addresses.
:local WarnAt 10
#Name of DHCP Pool you want to monitor
:local DHCPPoolName dhcp_pool1
#Your Email to notify you when running out of available ip's
:local Email my@email.com
#Your mail server ip address
:local EmailServer 0.0.0.0

#Declare Variable
:local Total

:foreach i in=[/ip pool get $DHCPPoolName ranges] do={
#Get the DHCP pool range and put into a string.
:local range [:tostr $i]
#Get the Start address of the range
:local Start [:pick $range 0 [:find $range "-"]]
#Get the End address of the range
:local Stop [:pick $range ([:find $range "-"] + 1) 31]
#Calculate how many IP's are in the Pool by subtracting the end address and the start address and add one.
:local ip ($Stop - $Start +1 )
#Save the size of the pool to Total
:set Total ($ip + $Total)
}

#Get the name of the Server that is using the Pool
:local Server [/ip dhcp-server get [/ip dhcp-server find address-pool="$DHCPPoolName"] name]
#Get the number of IP address's used in the pool
:local Used [/ip dhcp-server lease print count-only where server=[/ip dhcp-server get [/ip dhcp-server find address-pool=$DHCPPoolName] name]]
#Subtract used from total to get available
:local Available ($Total - $Used)
#Calculate percentage IP's available
:local Perc (($Available * 100) / $Total)
#Setup e-mail
:local Subject ([/system identity get name] . " DHCP pool is at $Perc")
:local Body ("Out of $Total addresses you have $Available available")

#Send out Email when available ip's percentage is below or equal to warnat
:if ($Perc <= $WarnAt) do={
/tool e-mail send to=$Email subject=$Subject body=$Body server=$EmailServer
}
:log info $Body

menyisipkan “.” pada awal baris dengan vi

Dari milist linux.or.id

:%s/^/./    menyisipkan titik (.) diawal setiap baris
:%s/$/./    menyisipkan titik (.) diakhir setiap baris

Script to save logs and send via email

Diambil dari forum.mikrotik.com

Script ini hanya berjalan di versi 3.x, di versi 2.9.x tidak berjalan, apalagi versi 2.9.27

Pastikan anda sudah mengisi server dan from di konfigurasi mikrotik.

/system script add name="LogDump" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="
:local body
:foreach int in=[/log find ] do={
  :set body ("$body\r\n" . [/log get $int])
}
/tool e-mail send to="YOU@DOMAIN.COM" subject=([/system identity get name] . " Log " . [/system clock get date]) body=$body
/system logging action set memory memory-lines=1
/system logging action set memory memory-lines=100"

Read more »

Mikrotik: case hotspot stiki.ac.id

Kasus ini ditanyakan ke saya oleh mas Ronny Susetyo aka ballacksave, admin (ngaku-nya newbie) stiki.ac.id via YM

topologi-stiki.gif

Nah pertanyaan saya pada dasarx sama seperti dasep yaitu bgm client yg di bawah mikrotik
(dosen, sabarnet,hotspot) klo buka jaringan yg diatas mikrotik seperti webserver, mail dan webhosting (203.134.237.0/29) bisa nggak ke limit, tapi klo browsing ke internet tetep ke limit.
nb:
di mikrotikx saya pake /ip hotspot, untuk bagi2 bandwidthx……
mohon pencerahan…

Read more »